[][src]Function transaction_builder::encode_update_dual_attestation_limit_script

pub fn encode_update_dual_attestation_limit_script(
    sliding_nonce: u64,
    new_micro_lbr_limit: u64
) -> Script

Summary

Update the dual attestation limit on-chain. Defined in terms of micro-LBR. The transaction can only be sent by the Treasury Compliance account. After this transaction all inter-VASP payments over this limit must be checked for dual attestation.

Technical Description

Updates the micro_lbr_limit field of the DualAttestation::Limit resource published under 0xA550C18. The amount is set in micro-LBR.

Parameters

NameTypeDescription
tc_account&signerThe signer reference of the sending account of this transaction. Must be the Treasury Compliance account.
sliding_nonceu64The sliding_nonce (see: SlidingNonce) to be used for this transaction.
new_micro_lbr_limitu64The new dual attestation limit to be used on-chain.

Common Abort Conditions

Error CategoryError ReasonDescription
Errors::NOT_PUBLISHEDSlidingNonce::ESLIDING_NONCEA SlidingNonce resource is not published under tc_account.
Errors::INVALID_ARGUMENTSlidingNonce::ENONCE_TOO_OLDThe sliding_nonce is too old and it's impossible to determine if it's duplicated or not.
Errors::INVALID_ARGUMENTSlidingNonce::ENONCE_TOO_NEWThe sliding_nonce is too far in the future.
Errors::INVALID_ARGUMENTSlidingNonce::ENONCE_ALREADY_RECORDEDThe sliding_nonce has been previously recorded.
Errors::REQUIRES_ADDRESSCoreAddresses::ETREASURY_COMPLIANCEtc_account is not the Treasury Compliance account.

Related Scripts